Errors running HARk in Ubuntu 16.4

HARK FORUM Errors running HARk in Ubuntu 16.4

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1368
    AvatarRiya Parth Dube
    Participant

    Hello
    I am trying to run my HARK network but it shows me execution error. Please help me solve it.I am inserting image for reference. Thank you.

    #1371
    Avatarlapus.er
    Participant

    Hello Riya,

    We’ll help you resolve your problem. But, before we can do that, we need to know the exact error that you encountered. The image that you uploaded is unintelligible, even after rotating the image clockwise – we are unable to read the exact error from the image.

    I have two suggestions, you can do either one:
    1) Copy the error from the browser and paste the text in a .txt file and send the file as an attachment.
    2) Produce a screenshot using the instructions here: https://help.ubuntu.com/stable/ubuntu-help/screen-shot-record.html and send the image file as an attachment.

    We will wait for your response.

    Cheers,
    HARK Support Team

    • This reply was modified 1 month ago by Avatarlapus.er.
    #1373
    AvatarRiya Parth Dube
    Participant

    Hi thank you for responding and apologies for the bad image quality. I am uploading a new image please guide me through it.

    #1375
    Avatarlapus.er
    Participant

    Hi Riya,

    It looks to me like the error is coming from the AudiostreamFromMic node.

    Can you please attach the network file that you were trying to execute? In case you do not know where this is located, it is in the /usr/lib/hark-designer/userdata/networks directory. The file name is basically the file indicated on the upper right portion of the Hark Designer user interface.

    Also, can you please post the type of microphone device that you are using?

    Cheers,
    HARK Support Team

    • This reply was modified 4 weeks ago by Avatarlapus.er.
    #1376
    AvatarRiya Parth Dube
    Participant

    Hi
    I am attaching the network I use and file name.

    #1381
    Avatarlapus.er
    Participant

    Hi Riya,

    The error displayed (from the attachment on your second post) indicated that an exception occurred on an AudioStreamFromMic node.

    However, looking at the latest attachments that you posted, the network dosen’t have an AudioStreamFromMic node but rather an AudioStreamFromWave node.

    So to clarify, what node do you intend to use in your network? AudioStreamFromWave or AudioStreamFromMic?

    Cheers,
    HARK Support Team

    • This reply was modified 4 weeks, 1 day ago by Avatarlapus.er.
    • This reply was modified 4 weeks ago by Avatarlapus.er.
    #1383
    AvatarRiya Parth Dube
    Participant

    I am using audio stream from wave node.

    #1384
    Avatarlapus.er
    Participant

    Hi Riya,

    Thank you for clarifying that bit.

    So, when you ran the network that uses the AudioStreamFromWave node, what error did you encounter? I am asking this because the error that you posted was an error emitted by AudioStreamFromMic and not AudioStreamFromWave.

    Cheers,
    HARK Support Team

    • This reply was modified 4 weeks ago by Avatarlapus.er.
    #1385
    AvatarRiya Parth Dube
    Participant

    It’s the same error for that as well.

    #1386
    Avatarlapus.er
    Participant

    Hi Riya,

    I attached an image with a piece of text highlighted in red.

    Can you please confirm if you are seeing the same text in the error message when you run the network that contains the AudioStreamFromWave node? I am asking this because the AudioStreamFromWave node is not expected to output such an error.

    Also, if it is possible, can you attach the wav file that you are using? I will try to replicate your network in my environment and check if I get the same error.

    Cheers,
    HARK Support Team

    • This reply was modified 4 weeks, 1 day ago by Avatarlapus.er.
    • This reply was modified 4 weeks ago by Avatarlapus.er.
    Attachments:
    #1389
    AvatarRiya Parth Dube
    Participant

    No I don’t get this message. Except that every thing is same. The sample audio is attached.
    Thank you.

    #1392
    Avatarlapus.er
    Participant

    Hi Riya,

    Thank you for sending the file.

    I replicated your network in my environment and here are the issues that I want to point out:
    1) The file that you are using is not a wav file but an mp3 file – AudioStreamFromWave cannot consume data from this file.
    2) You are indicating the file name in the LENGTH parameter of the AudioStreamFromWave node – this not where the file name is supposed to be indicated.
    3) You are using the output of MultiFFT as input to Synthesize – Synthesize expects a different data container, specifically a Map. While MulitFFT outputs a Matrix.

    Solutions:
    For #1: convert the file to wav
    For #2: Add a Constant node and an InputStream node to specify the correct file name
    For #3: Add a MatrixToMap node to make the output MultiFFT compatible with the Synthesize input

    I am attaching a sample network file that I tested on my environment.
    Please try it on your end. All you have to do is replace the value in the Constant node to the file name of your wav file. On Ubuntu, make sure to copy the wav file in the /usr/lib/hark-designer/userdata/networks directory.

    Let me know know how it goes.

    Cheers,
    HARK Support Team

    • This reply was modified 4 weeks ago by Avatarlapus.er.
    • This reply was modified 4 weeks ago by Avatarlapus.er.
    • This reply was modified 4 weeks ago by Avatarlapus.er.
    #1402
    AvatarRiya Parth Dube
    Participant

    Hi thank you for the response, the error got solved with that and i am finally able to get the output.
    thank you.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.