kei_15

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: AudioStreamFromRosによる録音について #1247
    Avatarkei_15
    Participant

    解決しました。
    ADVANCEの値をLENGTHと同じ値にしたところ正しく録音できました。
    失礼しました。

    in reply to: AudioStreamFromRosによる録音について #1246
    Avatarkei_15
    Participant

    補足です。

    wavファイルから音声データの取得をmultichannel_wav_reader.pyにて行なっています。
    その後、HARKへの送信をmultichannel_wav_reader.cppにて行なっております。
    (pythonで行うとエラーが起きたためこのような形になっています。)

    in reply to: hark-python3のチュートリアルでエラー #916
    Avatarkei_15
    Participant

    ご返信ありがとうございます。

    指摘していただいた通りにアンインストールとコードの修正を行い、無事に動作確認を行うことができました。
    丁寧な解説ありがとうございました。
    引き続きHARKを用いて独自のシステム構築を図っていきます。

    in reply to: ノードの作成方法について #869
    Avatarkei_15
    Participant

    失礼しました。
    $ sudo apt-get install hark-python3
    で無事、python関連のノードをhark_designer上に表示させることができました。

    もう1点質問がございます。
    頂いたpythonに関するページではConstantで定義をした変数をPython3で書かれた関数に渡しているようですが、逆の処理も可能でしょうか。
    つまり、PythonファイルからHARKへの通信に関しての処理です。

    何度も質問すみません。
    ご返答、お待ちしております。

    • This reply was modified 10 months ago by Avatarkei_15.
    in reply to: ノードの作成方法について #868
    Avatarkei_15
    Participant

    迅速なご対応ありがとうございます。

    HARK-Pythonの資料確認いたしました。
    こちらを参考にして、まずはPythonで実装を行おうと考えます。

    早速インストールを行ったところ以下のようなエラーが出ました。
    `
    $ sudo apt-get install hark-python
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    hark-python : Depends: flowdesigner-0.9.1-hark but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    `

    その後、こちらを参考にしてflowdesigner-0.9.1-harkをエラーなくmake installできたのですが、依然、上記のエラーが出てしまいます。

    なにかご存知でしたらご教授の程、よろしくお願い致します。

Viewing 5 posts - 1 through 5 (of 5 total)