Steph

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: Incorrect SemiBlindICA work on my network #1074
    Steph
    Participant

    Hello!
    Please write if I violated the rules of the forum and will not receive a response.
    If I asked an incorrect question, then I rephrase it in accordance with the requirements of the forum. Thank you!

    in reply to: Incorrect SemiBlindICA work on my network #1055
    Steph
    Participant

    2) A question concerning several parameters.

    – The LENGTH and WINDOW_LENGTH parameters are in many modules. Do they have to be the same everywhere?

    – In my case MSG_BUFFER_NUM and DATA_BUFFER_NUM in StreamFromHarkMsgs are equal in size of the buffer sent in the HarkWave message, is this correct? Or do I need to specify the queue size which is set when writing messages to the topic?

    3) The HarkWave message contains count. It is equal to seq from header. Am I doing the right thing?

    4) HarkWaveVal from HarkWave implies vector <float>. When saving data directly to a file, we get clear sound. After writing a message to HarkWave topic, we catch it by StreamFromHarkMsgs node and write to the file. In this case strong noises appear in the file. Do I need some kind of additional changes in order to transmit through the topic, or do I need to write to the topic just a set of bytes?

    5) When recording in ROS-topic, we set the size of the stored queue. Do I need to Indicate it in some of the nodes in hark_designer?

    in reply to: SemiBlindICA Connection #1018
    Steph
    Participant

    Thank you so much!
    If other questions arise, may I ask them here?

    • This reply was modified 2 years, 3 months ago by Steph.
    in reply to: SemiBlindICA Connection #997
    Steph
    Participant

    I think I set some parameters incorrectly. But I can’t figure out which ones when the system is very slow.

    • This reply was modified 2 years, 3 months ago by Steph.
    in reply to: SemiBlindICA Connection #992
    Steph
    Participant

    Thanks for the fast reply!

    I tried this connection scheme. In this case, the system is very slow. I can say that it hangs. Even if we set the parameter ROS_LOOP_RATE much less than the default value.

    • This reply was modified 2 years, 3 months ago by Steph.
    • This reply was modified 2 years, 3 months ago by Steph.
Viewing 5 posts - 1 through 5 (of 5 total)